5 votos

¿Cuál es el MacOSX.sdk de archivo? ¿Dónde puedo encontrarlo?

Estoy tratando de hacer una versión de Cyanogenmod, que muestra el error:

Can not find SDK  at /Developer/SDKs/MacOSX.sdk

Sin embargo, el /Developer/SDKs directorio no existe. Sé que la mayoría de las bibliotecas se han movido a Applications/Xcode.app/Contents/, pero no sé dónde buscar. ¿Qué es esto MacOSX.sdk de archivo? Donde lo puedo encontrar?

También tenga en cuenta que la wiki de Cyanogenmod dice que debo Instalar el Mac OS X de Herramientas de Desarrollador de mi DVD, pero he actualizado a Mavericks con la App Store. ¿Qué quieren decir con Herramientas de Desarrollador? Tengo cosas como make y gcc (herramientas de línea de Comandos en Xcode).

Esta es la página de la wiki he encontrado las instrucciones para instalar dev herramientas de DVD:

http://wiki.cyanogenmod.org/w/Template:Build_on_Mac_OS_X#Install_Developer_Tools

3voto

klanomath Puntos 19587

Como se ha mencionado por la Marca en los comentarios las instrucciones están hechas para versiones anteriores de Xcode.

En mi opinión, usted puede simplemente enlazar un MacOSX sdk /Desarrollador/Sdk:

sudo mkdir -p /Developer/SDKs
sudo ln -s /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.8.sdk /Developer/SDKs/MacOSX.sdk

además, se puede añadir un enlace llamado MacOSX10.6.sdk

sudo ln -s /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.8.sdk /Developer/SDKs/MacOSX10.6.sdk

Otra sugerencia es editar el build/core/combo/mac_version.mk y el cambio: mac_sdk_versions_supported := 10.6 10.7 10.8 a mac_sdk_versions_supported := 10.6 10.7 10.8 10.9 10.10


Recomiendo encarecidamente el uso de una máquina virtual (Lion de Montaña) y una más vieja versión de Xcode (4.6.3). Esta versión así como todas las otras versiones están disponibles libremente con un ID de Apple en Descargas para los Desarrolladores de Apple

1voto

Oskar Puntos 1242

Las viejas versiones de Xcode utiliza para instalar ellos mismos y archivos en el /Desarrollador carpeta.

Este no es el caso, entonces usted necesita para buscar y descargar la misma versión de Xcode que su paquete de espera o el paquete de actualización.

Si usted ha pagado una desarrollador, usted podría ser capaz de encontrar ese viejo paquete entre las descargas y volver a instalar. Peor de los casos, usted podría pedir desarrollador de apoyo para una descarga si usted no puede encontrar una vez que hayas iniciado sesión. Esto probablemente va a ser mucho más fácil que tratar de cambiar el código para que funcione con el nuevo Xcode instalación/diseño.

AppleAyuda.com

AppleAyuda es una comunidad de usuarios de los productos de Apple en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros usuarios, hacer tus propias preguntas o resolver las de los demás.

Powered by: