7 votos

¿Cómo puedo instalar iPhone Simulator 4.2 en Xcode 4.2?

Desarrollador De Información:

Versión: 4.2 (4D199) Ubicación: /Desarrollador Aplicaciones: Xcode: 4.2 (828) Instrumentos: 4.2 (4233) Dashcode: 3.0.2 (336) Sdk: Mac OS X: 10.6: (10K549) 10.7: (11C63) iPhone OS: 5.0: (9A334) iPhone Simulator: 4.3: (8H7) 5.0: (9A334)

Como se puede ver, Xcode4.2 está instalado y esto apoya iOS4.3, 5.0 simulador.
¿Cómo puedo probar la aplicación para el iOS4.2?
Debo instalar Xcode 3.x?

Gracias de antemano.

12voto

sandy Puntos 21
  • Descargar xcode_3.2.6_and_ios_sdk_4.3.dmg (nota: usted necesita una cuenta de desarrollador para acceder a este software. En lugar de eso he vinculado a un abierto al público de Apple discusión que contiene el enlace de descarga directa
  • El monte de el .archivo dmg
  • En la imagen del disco hay un invisible "Paquetes" de la carpeta. Para abrirlo, seleccione "Ir a la carpeta..." comando desde el Buscador de la barra de menú y digitar la ruta "/Volumes/Xcode y el SDK de iOS/Paquetes/"
  • Ahora haga doble clic en "iPhoneSimulatorSDK4_2.pkg"
  • Haga clic en el disco de destino y un botón de "Seleccionar carpeta..." será revelado
  • Haga clic en el botón de arriba y seleccione el "Desarrollador" en la carpeta
  • Instalar el paquete, y Reiniciar el Xcode.

Esto va a instalar el Simulador 4.2 SDK (tanto el iPad y el iPhone) dentro de la carpeta "/Desarrollador/Plataformas/iPhoneSimulator.plataforma/Desarrollador/SDKs/"

Ahora dentro de XCode 4.2 puede seleccionar este simulador desde el menú.

Bye.

2voto

Adam Puntos 144

La respuesta dada anteriormente no funciona para mí; nunca tuve un select-botón de la carpeta, y el 4.2 simulador terminó en /Platforms/iPhoneSimulator.platform/Developer/SDKs, que no está donde el 4.2 y 5.0 simuladores de vivir; y aunque he reiniciado Xcode, no 4.2 simulador apareció allí.

Yo manualmente movió junto a los demás (en /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs), el uso de sudo mv en la Terminal. Luego he reiniciado de nuevo Xcode, pero todavía no 4.2 simulador. Por el momento, estoy perplejo.

1voto

marbot Puntos 39

Si tienes un iPhone OS 3.x del dispositivo, y el plan de prueba en el dispositivo, entonces usted no necesita instalar Xcode 3 o Xcode 4.0 o Xcode 4.1 como Xcode 4.2 opcional (ver en la sección de Xcode 4.2 Preferencias -> pestaña de Descargas -> Componentes de la ficha) instalar que usted sólo tiene que descargar.

Si no tienes un iPhone 0S 3.x dispositivo, y quiere utilizar el simulador, usted puede instalar una anterior Xcode (que tiene el simulador desea) en una ruta diferente a la de Xcode 4.2. No instale tanto el uso de la ruta de acceso predeterminada o en el mismo camino, ya que puede hacer que su entorno de desarrollo inestable y "sudo /Biblioteca/desinstalar-devtools" no ayuda entonces.

[Nota para el moderador] Esta pregunta debe ser migrado a stackoverflow.com.

1voto

Rabih harb Puntos 111

es muy simple

usted tiene Xcode 4.2.1

abrir xcode > preferencias> Descargas> (pestaña)

y usted debe tener una lista de los simuladores para descargar e instalar

Disfrute de

-1voto

Ian Purton Puntos 121

http://www.touch-code-magazine.com/installing-4-3-iphone-simulator-in-xcode-4-2/

Parece trivial. Sólo tiene que repetir los pasos para 4.2

AppleAyuda.com

AppleAyuda es una comunidad de usuarios de los productos de Apple en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros usuarios, hacer tus propias preguntas o resolver las de los demás.

Powered by:

X