2 votos

¿Necesito la última versión de macOS para ejecutar Xcode y publicar aplicaciones macOS/iOS?

<p>Para liberar una aplicación a la App Store o construir uno necesita un Mac. Así que mi hermana me ofrecía su 2013 13" MacBook Air (128GB) para 200 € (~ $230). Todavía está funcionando bastante bien, precio-sabio vale (supongo).</p> <p>Pero he oído que para usar el Xcode, necesita la última versión, que generalmente está limitada a la última versión del sistema operativo.</p> <p>¿Es esto cierto? ¿Hago <strong>necesita</strong> el SO más reciente versión (Sierra alta a partir de ahora) para desarrollar y publicar aplicaciones de Mac/iOS?</p>

2voto

Monomeeth Puntos 139

La respuesta corta es no, no necesariamente.

Versiones de Xcode, como cualquier software, tendrá una versión mínima del sistema operativo que se requiere para ejecutar. Sin embargo, eso no es necesariamente la última versión del sistema operativo.

Algunos ejemplos:

  • Xcode 9.2 requiere como mínimo macOS Sierra 10.12.6 para ejecutar
  • Xcode 9.3 requiere como mínimo macOS Alta Sierra 10.13.2 para ejecutar

Esto pone de relieve el quid de la asunción en su pregunta - que necesita la última versión de Xcode para desarrollar y publicar aplicaciones. Sin embargo, esta suposición es falsa. Los desarrolladores no tienen que utilizar la última versión de Xcode para desarrollar y publicar aplicaciones para Mac o iOS App store. De hecho, usted no necesariamente tiene que usar Xcode.

Habiendo dicho todo eso, la última versión de Xcode (9.4.1) requiere macOS Alta Sierra 10.13.2 a ejecutar, así que en ese sentido se requiere la última versión de macOS (aunque no la última versión menor). Pero, como he dicho, no es necesario el uso de la última versión de Xcode para desarrollar y publicar una aplicación.

AppleAyuda.com

AppleAyuda es una comunidad de usuarios de los productos de Apple en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros usuarios, hacer tus propias preguntas o resolver las de los demás.

Powered by: