4 votos

Instalar las Versiones anteriores de Java en OS x 10.8.1

Tengo un MacBook Pro Retina, la ejecución de 10.8.1 y Java 1.6.0_35

Necesito instalar algunas versiones anteriores de Java con el fin de realizar un seguimiento de algunos bugs que mis clientes están viendo en las versiones anteriores de Java.

Traté de encontrar los instaladores para las versiones anteriores de Java del Apple Developer Network, pero ninguno de ellos va a instalar en la Montaña de Lion.

Donde puedo encontrar los instaladores para las versiones anteriores de Java? Específicamente, 1.6.0_07 y 1.5.0_xx que se ejecutará en OSX Mountain Lion?

1voto

Old Pro Puntos 2851

Usted simplemente no puede obtener arbitraria versiones de Java para Mac. Apple ofrece su propio Java binarios y no proveer a cada versión de Java. También, las versiones antiguas tienen problemas de seguridad conocidos con el hazañas en la naturaleza, por lo que es peligroso para utilizarlos en un sistema de escritorio.

Mi mejor recomendación sería la de crear una VM Linux usando VMware Fusion e instalar las versiones antiguas de cualquiera de los paquetes de Linux installer o el uso de los paquetes descargados de Oracle.

AppleAyuda.com

AppleAyuda es una comunidad de usuarios de los productos de Apple en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros usuarios, hacer tus propias preguntas o resolver las de los demás.

Powered by: